Hi everyone,

Every time I run my model (after 30 min with gap 99.8%), face "error 1001: out of memory" error! I set memory emphasis parameter to 1, working memory parameter to 1 and node file parameter to 2, to let cplex store node files on disk. However, the physical memory usage is yet at a high level and no node file is stored!!! Do you have any suggestions to carry out this problem?

for more information: i run the model on computer with 4G RAM, the version of CPLEX that i'm using is 12 and the log file output is:

Presolve time = 145.91 sec. Probing time = 0.95 sec. Clique table members: 1271. MIP emphasis: balance optimality and feasibility. MIP search method: dynamic search. Parallel mode: deterministic, using up to 4 threads. Root relaxation solution time = 7.18 sec.

Cover cuts applied: 263 Implied bound cuts applied: 19854 Flow cuts applied: 1356 Mixed integer rounding cuts applied: 6973 Zero-half cuts applied: 18 Gomory fractional cuts applied: 93

Total (root+branch&cut) = 1642.10 sec.

Warning: MIP starts not constructed because of out-of-memory status.

Thanks

asked 04 Mar '14, 04:34

dina's gravatar image

dina
013
accept rate: 0%

edited 04 Mar '14, 05:07

Bo%20Jensen's gravatar image

Bo Jensen ♦
5.0k2919

Are you using callbacks?

(04 Mar '14, 15:53) Paul Rubin ♦♦

Thanks for your comment Dr Rubin, No I didn't use callbacks

(05 Mar '14, 04:50) dina

In addition to @Bo's suggestions, I suggest to set the number of threads to one. Using the parallel optimization feature of CPLEX would result in consuming more memory. Although, based on your partial log, I'm not sure CPLEX has entered the parallel mode before the memory error or not. So this might have no effect.

link

answered 04 Mar '14, 05:05

Ehsan's gravatar image

Ehsan ♦
4.8k31122
accept rate: 16%

Thanks ehsan for your suggestion, I set the threads parameter to 1 and yes it works! Guess yours and jensen's suggestion together made it through. Thank you all

(05 Mar '14, 03:10) dina

@dina: You're most welcome. Good luck.

(05 Mar '14, 05:08) Ehsan ♦

Maybe it runs out of memory before root node is finished, hence why a nodefile is not written.

Please provide full log output.

I would assume CPLEX has an option ala "Focus on memory consumption ", try to look for parameter settings affecting memory usage.

You could also try depth first search to hopefully reduce memory usage in open nodes (of course only if nodes are being solved).

In case you just want to solve this instance, you could also take the best incumbent you have from the aborted run and input it for another solve (in fact I think CPLEX will do this by default, but I am not sure there might be issues when running out of memory).

link

answered 04 Mar '14, 04:43

Bo%20Jensen's gravatar image

Bo Jensen ♦
5.0k2919
accept rate: 14%

Thanks Bo Jensen for your response,

I took your advice and set node selection parameter to 0 to use depth-first search but, unfortunately, nothing happened and it still stops running at gap 99.8%.

(05 Mar '14, 03:09) dina

I think Ehsan's answer is probably what you need.

(05 Mar '14, 03:12) Bo Jensen ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×191
×4

Asked: 04 Mar '14, 04:34

Seen: 4,575 times

Last updated: 27 Dec '16, 02:56

OR-Exchange! Your site for questions, answers, and announcements about operations research.